3June2022

KCP Presets 2022

Written by uploader. Posted in Lightroom Presets

 KCP Presets 2022

KCP Presets 2022

For the preset pack you need at least Lightroom Classic 11.0 or higher and/or Adobe Photoshop 2021 or higher. Adobe Lightroom and Photoshop are NOT included in the package, but must already exist or be purchased separately. The package can be used on both Windows PC and Mac OS. The preset package is a 'digital product' and is made available as a file via a download link. This product is a desktop preset. Use on mobile apps is only possible to a limited extent. We assume no liability for this.

 

 


Dear visitor, you went to the site as unregistered user. We encourage you to create a free account and Login


» Go back   |   Views: 1083   |   0 Comments | |

Comments (0)

Information
Would you like to leave your comment? Please Login to your account to leave comments. Don't have an account? You can create a free account now.
TOP